IE7 and earlier are no longer supported

-

Back in September, we shared our plans to phase out support for IE7. IE7 was released in 2006, has officially been unsupported by Microsoft since April 2014, and should be considered insecure.

As of March 1, 2015, PolicyStat no longer supports IE7 in any capacity. By refocusing our efforts on supporting newer technology, PolicyStat is able to deliver more improvements on a faster schedule by using features available in modern browsers. We think this decision improves PolicyStat for everyone.

You, and any other users on your site still using IE7, will still be able to access PolicyStat, but you should expect that more and more features will stop working as time goes on. Features that site administrators use are the ones most likely to stop working sooner, rather than later, in unsupported browsers.

Please don't hesitate to contact us at support@policystat.com if you have any questions about this transition.

Have more questions? Submit a request

Comments